Hyperlink for previously signed documents is temporarily disabled
Incident Report for Traction Guest
Resolved
This incident has been resolved.
Posted 3 months ago. Nov 24, 2018 - 10:37 PST
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Nov 20, 2018 - 13:52 PST
Identified
We've temporarily disabled sign-in record hyperlinks to previously signed guest documents. We expect the direct link to previously signed documents to be made available again this week.

These documents are still accessible in the sign-in record that first signed the document. To access this link, go into the guest history and find the sign in record where the document was first signed.
Posted 3 months ago. Nov 20, 2018 - 13:52 PST