Platform latency on Guest web application
Incident Report for Traction Guest
Resolved
This is now resolved.

Our team identified an issue with how system tasks were being completed via the backend. We have since made some improvements to address this issue
Posted Jun 29, 2020 - 14:54 PDT
Update
We are still investigating root cause of the performance latency. The online web-app still remains functional, but some customers may encounter latency when navigating through parts of the platform.
Posted Jun 29, 2020 - 13:52 PDT
Investigating
Our team has identified some performance latency which may impact some customers navigating through the online web-app.
Posted Jun 29, 2020 - 12:03 PDT
This incident affected: Admin Console.