Suppress Primary Email is currently not working
Incident Report for Traction Guest
Resolved
This incident has been resolved.
Posted 5 months ago. Nov 29, 2018 - 08:07 PST
Identified
We've already identified the issue and are working on a fix for this.
Posted 5 months ago. Nov 28, 2018 - 10:35 PST
This incident affected: Notifications.