Email notifications provider issue
Incident Report for Traction Guest
Resolved
Email functionality is back to normal.
Posted over 1 year ago. May 31, 2018 - 16:01 PDT
Identified
Switching to back up provider. Backlogged emails will be sent shortly.
Posted over 1 year ago. May 31, 2018 - 15:25 PDT
This incident affected: Email Gateway.